will_paginate is broken in Rails 3.1 (UPDATED)

[UPDATE, 3 October 2012] The will_paginate gem has been updated since my original post and should now work with all recent versions of Rails (3.2.8 as of today). [end update]

[Original post]
Apparently, will_paginate was barely working with Rails 3.0, requiring users to specify a prerelease version of the gem that hadn’t been updated in ages. With Rails 3.1, even that no longer works, and will_paginate seems likely to be gone for good. Fortunately, RailsCasts has the solution! They suggest using kaminari, and so far so good. Not only has it not broken my app just by being installed, it’s also got some nifty features and is easy to understand.

About these ads

About joanwolk

3 things I like: theater, food, geekery. 3 things I don't like: clichés, blisters, coffee.
This entry was posted in Uncategorized. Bookmark the permalink.

One Response to will_paginate is broken in Rails 3.1 (UPDATED)

  1. *will_paginate* was updated and now supports all recent versions of rails, please update your post.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s